WP-Stateless – Google Cloud Storage <= 3.4.0 - Missing Authorization to Limited Arbitrary Options Update
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The WP-Stateless – Google Cloud Storage plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the dismiss_notices() function in all versions up to, and including, 3.4.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary option values to the current time, which may completely take a site offline.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| usability_dynamics | WP-Stateless – Google Cloud Storage | up to 3.4.0 | — | No fix listed | CNA |
- WP-Stateless – Google Cloud Storage Vendorusability_dynamics Affected up to 3.4.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1385
- 2026-10-03 Alias added: GHSA-78rg-c3vx-jc43
References
More usability_dynamics vulnerabilities
- TI-2022-01487 WP-Invoice <= 4.3.1 - Stored Cross-Site Scripting via CSRF CVSS 3.1MEDIUM 6.1
- TI-2022-01090 WP-CRM <= 1.2.1 - CSV Injection CVSS 3.1HIGH 7.8
- TI-2016-09049 The wp-invoice plugin before 4.1.1 for WordPress has wpi_update_user_option privilege escalation. CVSS 3.1MEDIUM 6.5
- TI-2016-09048 The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over… CVSS 3.1MEDIUM 5.3
- TI-2016-09047 The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over… CVSS 3.1MEDIUM 5.3
- TI-2016-09046 The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over wpi_paypal payer metadata updates. CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-1385 · CVE Program
- CVE-2024-1385 · NVD
- FIRST EPSS
- GHSA-78rg-c3vx-jc43 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences