Read the docs
TI-2024-01547 Aliases CVE-2024-1664GHSA-5hf5-fh77-h2w2

Responsive Gallery Grid < 2.3.11 - Admin+ Stored XSS

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Responsive Gallery Grid WordPress plugin before 2.3.11 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00492 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Responsive Gallery Grid (Unknown): 2.3.11

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownResponsive Gallery Gridbefore 2.3.112.3.11Patch availableCNA
  • Responsive Gallery Grid VendorUnknown Affected before 2.3.11 Fixed in 2.3.11 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:bdwm:responsive_gallery_grid:*:*:*:*:*:wordpress:*:*before 2.3.11VulnerableBdwm
  • cpe:2.3:a:bdwm:responsive_gallery_grid:*:*:*:*:*:wordpress:*:* Versions before 2.3.11 Vulnerable ·Bdwm

Remediation

  • Fix · CNA Responsive Gallery Grid (Unknown) Fixed in 2.3.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1664
  2. 2026-10-03 Alias added: GHSA-5hf5-fh77-h2w2

References

  • TI-2024-03811 Responsive Gallery Grid < 2.3.15 - Admin+ Stored XSS CVSS 3.1LOW 3.5
  • TI-2023-22084 WordPress Responsive Gallery Grid Plugin <= 2.3.10 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8

Sources