Read the docs
TI-2024-01685 Aliases CVE-2024-1809GHSA-g629-p7x4-5x6r

Analytify – Google Analytics Dashboard For WordPress (GA4 analytics made easy) <= 5.2.3 - Missing Authorization

Priority LOW 24CWE-497Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure, Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-497 and CWE-862.

Summary

The Analytify – Google Analytics Dashboard For WordPress (GA4 analytics made easy) plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on AJAX functions in combination with nonce leakage in all versions up to, and including, 5.2.3. This makes it possible for authenticated attackers, with subscriber access and higher, to obtain certain sensitive information related to plugin settings.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00291 21st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
hiddenpearlsAnalytify – Google Analytics Dashboard For WordPress (GA4 analytics tracking)up to 5.2.3—No fix listedCNA
  • Analytify – Google Analytics Dashboard For WordPress (GA4 analytics tracking) Vendorhiddenpearls Affected up to 5.2.3 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:analytify:analytify_-_google_analytics_dashboard:*:*:*:*:*:wordpress:*:*before 5.2.4VulnerableAnalytify
  • cpe:2.3:a:analytify:analytify_-_google_analytics_dashboard:*:*:*:*:*:wordpress:*:* Versions before 5.2.4 Vulnerable ·Analytify

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1809
  2. 2026-10-03 Alias added: GHSA-g629-p7x4-5x6r

References

  • TI-2025-01848 WP Headers And Footers <= 3.1.1 - Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 7.5
  • TI-2025-01520 LoginPress <= 3.3.1 - Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 7.5
  • TI-2022-04562 Freemius SDK <= 2.4.2 - Missing Authorization Checks CVSS 3.1MEDIUM 6.3

Sources