CSRF to RCE in significant-gravitas/autogpt
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
A Cross-Site Request Forgery (CSRF) vulnerability in significant-gravitas/autogpt version v0.5.0 allows attackers to execute arbitrary commands on the AutoGPT server. The vulnerability stems from the lack of protections on the API endpoint receiving instructions, enabling an attacker to direct a user running AutoGPT in their local network to a malicious website. This site can then send crafted requests to the AutoGPT server, leading to command execution. The issue is exacerbated by CORS being enabled for arbitrary origins by default, allowing the attacker to read the response of all cross-site queries. This vulnerability was addressed in version 5.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Significant-Gravitas | significant-gravitas/autogpt | before 5.1 | 5.1 | Patch available | CNA |
- significant-gravitas/autogpt VendorSignificant-Gravitas Affected before 5.1 Fixed in 5.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:agpt:autogpt_classic:0.5.0:*:*:*:*:*:*:* | 0.5.0 | Vulnerable | Significant-Gravitas |
- cpe:2.3:a:agpt:autogpt_classic:0.5.0:*:*:*:*:*:*:* Versions 0.5.0 Vulnerable ·Significant-Gravitas
Remediation
- Fix · CNA significant-gravitas/autogpt (significant-gravitas) Fixed in 5.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1879
- 2026-10-03 Alias added: GHSA-wwg8-x274-5x5g
References
More Significant-Gravitas Autogpt Classic vulnerabilities
- TI-2024-05646 Shell Command Denylist Bypass in significant-gravitas/autogpt CVSS 3.1CRITICAL 9.8
- TI-2024-07563 Command Injection in significant-gravitas/autogpt CVSS 3.1CRITICAL 9.8
- TI-2024-01750 Improper Neutralization of Special Elements used in an OS Command in significant-gravitas/autogpt CVSS 3.1CRITICAL 9.8
- TI-2024-01749 OS Command Injection in MacOS Text-To-Speech Class in significant-gravitas/autogpt CVSS 3.1HIGH 7.8
- TI-2023-18903 Docker escape in Auto-GPT when running from docker-compose.yml included in git repo CVSS 3.1HIGH 8.8
- TI-2023-18904 Python code execution sandbox escape in non-docker version in Auto-GPT CVSS 3.1HIGH 7.8
Sources
- CVE-2024-1879 · CVE Program
- CVE-2024-1879 · NVD
- FIRST EPSS
- GHSA-wwg8-x274-5x5g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences