OS Command Injection in MacOS Text-To-Speech Class in significant-gravitas/autogpt
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
An OS command injection vulnerability exists in the MacOS Text-To-Speech class MacOSTTS of the significant-gravitas/autogpt project, affecting versions up to v0.5.0. The vulnerability arises from the improper neutralization of special elements used in an OS command within the `_speech` method of the MacOSTTS class. Specifically, the use of `os.system` to execute the `say` command with user-supplied text allows for arbitrary code execution if an attacker can inject shell commands. This issue is triggered when the AutoGPT instance is run with the `--speak` option enabled and configured with `TEXT_TO_SPEECH_PROVIDER=macos`, reflecting back a shell injection snippet. The impact of this vulnerability is the potential execution of arbitrary code on the instance running AutoGPT. The issue was addressed in version 5.1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Significant-Gravitas | significant-gravitas/autogpt | before 5.1.0 | 5.1.0 | Patch available | CNA |
- significant-gravitas/autogpt VendorSignificant-Gravitas Affected before 5.1.0 Fixed in 5.1.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:agpt:autogpt_classic:*:*:*:*:*:*:*:* | before 0.5.1 | Vulnerable | Significant-Gravitas |
- cpe:2.3:a:agpt:autogpt_classic:*:*:*:*:*:*:*:* Versions before 0.5.1 Vulnerable ·Significant-Gravitas
Remediation
- Fix · CNA significant-gravitas/autogpt (significant-gravitas) Fixed in 5.1.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
significant-gravitas/autogpt 5.1.0
2 records Highest priority Priority HIGH 2 HIGH
Other records, highest priority first
- TI-2024-01750 Improper Neutralization of Special Elements used in an OS Command in significant-gravitas/autogptPriority HIGH 76
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1880
- 2026-10-03 Alias added: GHSA-rf3r-wjj9-3842
References
More Significant-Gravitas Autogpt Classic vulnerabilities
- TI-2024-05646 Shell Command Denylist Bypass in significant-gravitas/autogpt CVSS 3.1CRITICAL 9.8
- TI-2024-07563 Command Injection in significant-gravitas/autogpt CVSS 3.1CRITICAL 9.8
- TI-2024-01750 Improper Neutralization of Special Elements used in an OS Command in significant-gravitas/autogpt CVSS 3.1CRITICAL 9.8
- TI-2024-01748 CSRF to RCE in significant-gravitas/autogpt CVSS 3.1HIGH 8.8
- TI-2023-18903 Docker escape in Auto-GPT when running from docker-compose.yml included in git repo CVSS 3.1HIGH 8.8
- TI-2023-18904 Python code execution sandbox escape in non-docker version in Auto-GPT CVSS 3.1HIGH 7.8
Sources
- CVE-2024-1880 · CVE Program
- CVE-2024-1880 · NVD
- FIRST EPSS
- GHSA-rf3r-wjj9-3842 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences