Uncontrolled resource consumption in Mattermost
Priority LOW 21CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Mattermost versions 8.1.x before 8.1.9, 9.2.x before 9.2.5, 9.3.0, and 9.4.x before 9.4.2 fail to limit the number of role names requested from the API, allowing an authenticated attacker to cause the server to run out of memory and crash by issuing an unusually large HTTP request.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00508 43rd percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 9.5, 9.4.2, 9.3.1 +2github.com/mattermost/mattermost/server/v8 (Go): 9.4.2, 9.3.1, 9.2.5 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 9.4.0 – 9.4.1; 9.3.0; 9.2.0 – 9.2.4; 8.1.0 – 8.1.8 | 9.5, 9.4.2, 9.3.1, 9.2.5, 8.1.9 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.4.0 to before 9.4.2 | 9.4.2 | Patch available | GHSA-vm9m-57jr-4pxh |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.3.0 to before 9.3.1 | 9.3.1 | Patch available | GHSA-vm9m-57jr-4pxh |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.2.0 to before 9.2.5 | 9.2.5 | Patch available | GHSA-vm9m-57jr-4pxh |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.1.9 | 8.1.9 | Patch available | GHSA-vm9m-57jr-4pxh |
- Mattermost VendorMattermost Affected 9.4.0 – 9.4.1; 9.3.0; 9.2.0 – 9.2.4; 8.1.0 – 8.1.8 Fixed in 9.5, 9.4.2, 9.3.1, 9.2.5, 8.1.9 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.4.0 to before 9.4.2 Fixed in 9.4.2 Patch available GHSA-vm9m-57jr-4pxh
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.3.0 to before 9.3.1 Fixed in 9.3.1 Patch available GHSA-vm9m-57jr-4pxh
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.2.0 to before 9.2.5 Fixed in 9.2.5 Patch available GHSA-vm9m-57jr-4pxh
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.1.9 Fixed in 8.1.9 Patch available GHSA-vm9m-57jr-4pxh
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 8.1.0 to before 8.1.9; 9.2.0 to before 9.2.5; 9.4.0 to before 9.4.2 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:9.3.0:*:*:*:*:*:*:* | 9.3.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 8.1.0 to before 8.1.9; 9.2.0 to before 9.2.5; 9.4.0 to before 9.4.2 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:9.3.0:*:*:*:*:*:*:* Versions 9.3.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 9.5, 9.4.2, 9.3.1, 9.2.5, 8.1.9
- Fix · GHSA-vm9m-57jr-4pxh github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.4.2 Advisory →
- Fix · GHSA-vm9m-57jr-4pxh github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.3.1 Advisory →
- Fix · GHSA-vm9m-57jr-4pxh github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.2.5 Advisory →
- Fix · GHSA-vm9m-57jr-4pxh github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.1.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1953
- 2026-10-03 Alias added: GHSA-vm9m-57jr-4pxh
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-1953 · CVE Program
- CVE-2024-1953 · NVD
- FIRST EPSS
- GHSA-vm9m-57jr-4pxh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences