PHP is vulnerable to the Marvin Attack
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 fixed, 4 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-203.
Summary
The openssl_private_decrypt function in PHP, when using PKCS1 padding (OPENSSL_PKCS1_PADDING, which is the default), is vulnerable to the Marvin Attack unless it is used with an OpenSSL version that includes the changes from this pull request: https://github.com/openssl/openssl/pull/13817 (rsa_pkcs1_implicit_rejection). These changes are part of OpenSSL 3.2 and have also been backported to stable versions of various Linux distributions, as well as to the PHP builds provided for Windows since the previous release. All distributors and builders should ensure that this version is used to prevent PHP from being vulnerable. PHP Windows builds for the versions 8.1.29, 8.2.20 and 8.3.8 and above include OpenSSL patches that fix the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHP Group | PHP | before 8.1.29; before 8.2.20; before 8.3.8 | 8.1.29, 8.2.20, 8.3.8 | Patch available | CNA |
- PHP VendorPHP Group Affected before 8.1.29; before 8.2.20; before 8.3.8 Fixed in 8.1.29, 8.2.20, 8.3.8 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | 8.1.0 to before 8.1.29; 8.2.0 to before 8.2.20; 8.3.0 to before 8.3.8 | Vulnerable | PHP |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 8.1.0 to before 8.1.29; 8.2.0 to before 8.2.20; 8.3.0 to before 8.3.8 Vulnerable ·PHP
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA PHP (PHP Group) Fixed in 8.1.29, 8.2.20, 8.3.8
Red Hat 1 advisory
- RHSA-2023:7877 Released 2023-12-19 · Red Hat rating Lowopenssl security update
- Red Hat Enterprise Linux BaseOS (v. 8) openssl-1:1.1.1k-12.el8_9, openssl-devel-1:1.1.1k-12.el8_9, openssl-libs-1:1.1.1k-12.el8_9 +1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PHP 8.1.29, 8.2.20, 8.3.8
4 records Highest priority Priority CRITICAL 1 CRITICAL, 1 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2024-04260 Argument Injection in PHP-CGIPriority CRITICAL 100
- TI-2024-05189 Command injection via array-ish $command parameter of proc_open() (bypass CVE-2024-1874 fix)Priority HIGH 73
- TI-2024-05072 Filter bypass in filter_var (FILTER_VALIDATE_URL)Priority MEDIUM 63
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2023:7877 |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2408
References
More PHP Group vulnerabilities
- TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
- TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
- TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
- TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
- TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
- TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-2408 · CVE Program
- CVE-2024-2408 · NVD
- FIRST EPSS
- CVE-2024-2408 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences