Easy Property Listings <= 3.5.3 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Easy Property Listings WordPress plugin before 3.5.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Easy Property Listings (Unknown): 3.5.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Easy Property Listings | before 3.5.4 | 3.5.4 | Patch available | CNA |
- Easy Property Listings VendorUnknown Affected before 3.5.4 Fixed in 3.5.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:realestateconnected:easy_property_listings:*:*:*:*:*:wordpress:*:* | before 3.5.4 | Vulnerable | Realestateconnected |
- cpe:2.3:a:realestateconnected:easy_property_listings:*:*:*:*:*:wordpress:*:* Versions before 3.5.4 Vulnerable ·Realestateconnected
Remediation
- Fix · CNA Easy Property Listings (Unknown) Fixed in 3.5.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2869
- 2026-10-03 Alias added: GHSA-wr8q-wf72-mf6m
References
More Realestateconnected Easy Property Listings vulnerabilities
- TI-2024-02963 Easy Property Listings < 3.5.4 - Arbitrary Contact Deletion via CSRF CVSS 3.1MEDIUM 4.3
- TI-2024-21673 WordPress Easy Property Listings plugin <= 3.5.3 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2020-04500 Cross-site request forgery in Merv Barrett Easy Property Listings CVSS 3.1HIGH 8.8
- TI-2024-01762 Easy Property Listings <= 3.5.2 - Authenticated(Contributor+) SQL Injection via Shortcode CVSS 3.1HIGH 8.8
- TI-2019-11884 The easy-property-listings plugin before 3.4 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2024-2869 · CVE Program
- CVE-2024-2869 · NVD
- FIRST EPSS
- GHSA-wr8q-wf72-mf6m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences