Save as PDF by Pdfcrowd < 3.2.2 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Save as Image Plugin by Pdfcrowd WordPress plugin before 3.2.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Save as Image Plugin by Pdfcrowd (Unknown): 3.2.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Save as Image Plugin by Pdfcrowd | before 3.2.2 | 3.2.2 | Patch available | CNA |
- Save as Image Plugin by Pdfcrowd VendorUnknown Affected before 3.2.2 Fixed in 3.2.2 Patch available CNA
Remediation
- Fix · CNA Save as Image Plugin by Pdfcrowd (Unknown) Fixed in 3.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3062
- 2026-10-03 Alias added: GHSA-f8vr-vg6x-hfpr
References
More Pdfcrowd Save As Pdf vulnerabilities
- TI-2023-05502 Save as PDF < 3.2.0 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-23518 WordPress Save as PDF Plugin by Pdfcrowd plugin <= 3.2.3 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-10095 Save as PDF Plugin by Pdfcrowd <= 4.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2023-21460 WordPress Save as PDF plugin by Pdfcrowd Plugin <= 2.16.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
- TI-2024-25049 WordPress Save as PDF plugin by Pdfcrowd plugin <= 4.0.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-3062 · CVE Program
- CVE-2024-3062 · NVD
- FIRST EPSS
- GHSA-f8vr-vg6x-hfpr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences