Read the docs
TI-2024-03259 Aliases CVE-2024-3494GHSA-gc8p-39g7-4mhp

Cross-site scripting in horearadu Mesmerize Companion

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The Mesmerize Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'mesmerize_contact_form' shortcode in all versions up to, and including, 1.6.148 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00333 26th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
horearaduMesmerize Companionup to 1.6.148—No fix listedCNA
  • Mesmerize Companion Vendorhorearadu Affected up to 1.6.148 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-3494
  2. 2026-10-03 Alias added: GHSA-gc8p-39g7-4mhp

References

  • TI-2024-04380 Cross-site scripting in horearadu Materialis Companion CVSS 3.1MEDIUM 6.4
  • TI-2024-04376 Cross-site scripting in horearadu One Page Express Companion CVSS 3.1MEDIUM 6.4
  • TI-2025-11026 Mesmerize Companion <= 1.6.158 - Missing Authorization Authenticated (Subscriber+) Settings Update CVSS 3.1MEDIUM 4.3
  • TI-2026-19783 WordPress Materialis Companion plugin <= 1.3.52 - Broken Access Control vulnerability CVSS 3.1MEDIUM 4.3
  • TI-2025-38375 WordPress One Page Express Companion plugin <= 1.6.43 - Broken Access Control vulnerability CVSS 3.1MEDIUM 4.3

Sources