Cross-site scripting in horearadu Materialis Companion
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Materialis Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's materialis_contact_form shortcode in all versions up to, and including, 1.3.41 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| horearadu | Materialis Companion | up to 1.3.41 | — | No fix listed | CNA |
- Materialis Companion Vendorhorearadu Affected up to 1.3.41 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:extendthemes:materialis_companion:*:*:*:*:*:wordpress:*:* | before 1.3.42 | Vulnerable | extendthemes |
- cpe:2.3:a:extendthemes:materialis_companion:*:*:*:*:*:wordpress:*:* Versions before 1.3.42 Vulnerable ·extendthemes
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4707
- 2026-10-03 Alias added: GHSA-vhgg-c8h4-x9hr
References
Patch 2
More horearadu vulnerabilities
- TI-2024-04376 Cross-site scripting in horearadu One Page Express Companion CVSS 3.1MEDIUM 6.4
- TI-2024-03259 Cross-site scripting in horearadu Mesmerize Companion CVSS 3.1MEDIUM 6.4
- TI-2025-11026 Mesmerize Companion <= 1.6.158 - Missing Authorization Authenticated (Subscriber+) Settings Update CVSS 3.1MEDIUM 4.3
- TI-2026-19783 WordPress Materialis Companion plugin <= 1.3.52 - Broken Access Control vulnerability CVSS 3.1MEDIUM 4.3
- TI-2025-38375 WordPress One Page Express Companion plugin <= 1.6.43 - Broken Access Control vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-4707 · CVE Program
- CVE-2024-4707 · NVD
- FIRST EPSS
- GHSA-vhgg-c8h4-x9hr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences