Shortcodes Ultimate < 7.1.2 - Contributor+ Stored XSS
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Shortcodes Plugin — Shortcodes Ultimate WordPress plugin before 7.1.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00441 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Shortcodes Plugin — Shortcodes Ultimate (Unknown): 7.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Shortcodes Plugin — Shortcodes Ultimate | before 7.1.2 | 7.1.2 | Patch available | CNA |
- WP Shortcodes Plugin — Shortcodes Ultimate VendorUnknown Affected before 7.1.2 Fixed in 7.1.2 Patch available CNA
Remediation
- Fix · CNA WP Shortcodes Plugin — Shortcodes Ultimate (Unknown) Fixed in 7.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3548
- 2026-10-03 Alias added: GHSA-fgjm-9hpr-9w7r
References
More gn_themes Shortcodes Ultimate vulnerabilities
- TI-2023-00863 Shortcodes Ultimate < 5.12.8 - Subscriber+ User Meta Disclosure CVSS 3.1MEDIUM 6.5
- TI-2023-00842 Shortcodes Ultimate < 5.12.8 - Subscriber+ Arbitrary Post Access CVSS 3.1MEDIUM 6.5
- TI-2024-02988 Shortcodes Ultimate < 7.1.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.3
- TI-2024-06270 Shortcodes Ultimate Pro < 7.2.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-02402 Shortcodes Ultimate < 7.0.5 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2017-13753 The shortcodes-ultimate plugin before 5.0.1 for WordPress has remote code execution via a… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-3548 · CVE Program
- CVE-2024-3548 · NVD
- FIRST EPSS
- GHSA-fgjm-9hpr-9w7r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences