BA Book Everything <= 1.6.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The BA Book Everything plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'all-items' shortcode in all versions up to, and including, 1.6.8 due to insufficient input sanitization and output escaping on user supplied attributes such as 'classes'. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-32576 is likely a duplicate of this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| bookingalgorithms | BA Book Everything | up to 1.6.8 | — | No fix listed | CNA |
- BA Book Everything Vendorbookingalgorithms Affected up to 1.6.8 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ba-booking:ba_book_everything:*:*:*:*:*:wordpress:*:* | before 1.6.9 | Vulnerable | bookingalgorithms |
- cpe:2.3:a:ba-booking:ba_book_everything:*:*:*:*:*:wordpress:*:* Versions before 1.6.9 Vulnerable ·bookingalgorithms
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3672
- 2026-10-03 Alias added: GHSA-8p8h-55m5-85pr
References
More bookingalgorithms Ba Book Everything vulnerabilities
- TI-2024-08161 BA Book Everything <= 1.6.20 - Cross-Site Request Forgery to Email Address Update/Account Takeover CVSS 3.1HIGH 8.8
- TI-2024-21200 WordPress BA Book Everything plugin <= 1.6.4 - Auth. SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-31678 WordPress BA Book Everything plugin <= 1.6.20 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-08160 BA Book Everything <= 1.6.20 - Unauthenticated Arbitrary User Password Reset CVSS 3.1MEDIUM 5.3
- TI-2024-21463 WordPress BA Book Everything plugin <= 1.6.8 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-21485 WordPress BA Book Everything plugin <= 1.6.8 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-3672 · CVE Program
- CVE-2024-3672 · NVD
- FIRST EPSS
- GHSA-8p8h-55m5-85pr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences