WordPress BA Book Everything plugin <= 1.6.8 - Cross Site Scripting (XSS) vulnerability
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Booking Algorithms BA Book Everything allows Stored XSS.This issue affects BA Book Everything: from n/a through 1.6.8.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00325 25th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| bookingalgorithms | BA Book Everything | up to 1.6.8 | — | No fix listed | CNA |
- BA Book Everything Vendorbookingalgorithms Affected up to 1.6.8 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ba-booking:ba_book_everything:*:*:*:*:*:wordpress:*:* | before 1.6.9 | Vulnerable | bookingalgorithms |
- cpe:2.3:a:ba-booking:ba_book_everything:*:*:*:*:*:wordpress:*:* Versions before 1.6.9 Vulnerable ·bookingalgorithms
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32598
- 2026-10-03 Alias added: GHSA-ffg5-77xm-p7h2
References
More bookingalgorithms Ba Book Everything vulnerabilities
- TI-2024-08161 BA Book Everything <= 1.6.20 - Cross-Site Request Forgery to Email Address Update/Account Takeover CVSS 3.1HIGH 8.8
- TI-2024-21200 WordPress BA Book Everything plugin <= 1.6.4 - Auth. SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-31678 WordPress BA Book Everything plugin <= 1.6.20 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-08160 BA Book Everything <= 1.6.20 - Unauthenticated Arbitrary User Password Reset CVSS 3.1MEDIUM 5.3
- TI-2024-21463 WordPress BA Book Everything plugin <= 1.6.8 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-03426 BA Book Everything <= 1.6.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-32598 · CVE Program
- CVE-2024-32598 · NVD
- FIRST EPSS
- GHSA-ffg5-77xm-p7h2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences