Read the docs
TI-2024-03445 Aliases CVE-2024-3692GHSA-fxmj-37cj-x4r5

Gutenverse < 1.9.1 - Contributor+ Stored XSS

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Gutenverse WordPress plugin before 1.9.1 does not validate the htmlTag option in various of its block before outputting it back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00442 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Gutenverse (Unknown): 1.9.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownGutenverse before 1.9.11.9.1Patch availableCNA
  • Gutenverse VendorUnknown Affected before 1.9.1 Fixed in 1.9.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jegstudio:gutenverse:*:*:*:*:free:wordpress:*:*before 1.9.1Vulnerablejegstudio
  • cpe:2.3:a:jegstudio:gutenverse:*:*:*:*:free:wordpress:*:* Versions before 1.9.1 Vulnerable ·jegstudio

Remediation

  • Fix · CNA Gutenverse (Unknown) Fixed in 1.9.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-3692
  2. 2026-10-03 Alias added: GHSA-fxmj-37cj-x4r5

References

  • TI-2025-02528 Gutenverse <= 2.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via countdown Block CVSS 3.1MEDIUM 6.4
  • TI-2024-29509 Cross-site scripting in jegstudio Gutenverse CVSS 3.1MEDIUM 6.5
  • TI-2024-26018 WordPress Gutenverse plugin <= 1.9.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5

Sources