Read the docs
TI-2024-03635 Aliases CVE-2024-3895GHSA-6r8w-jhg7-gpr9

WP Datepicker <= 2.1.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update

Priority MEDIUM 42CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The WP Datepicker plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpdp_add_new_datepicker_ajax() function in all versions up to, and including, 2.1.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary options that can be used for privilege escalation. This was partially patched in 2.0.9 and 2.1.0, and fully patched in 2.1.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00911 60th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
fahadmahmoodWP Datepickerup to 2.1.0—No fix listedCNA
  • WP Datepicker Vendorfahadmahmood Affected up to 2.1.0 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:androidbubbles:wp_datepicker:*:*:*:*:*:wordpress:*:*before 2.1.1VulnerableAndroidbubbles
  • cpe:2.3:a:androidbubbles:wp_datepicker:*:*:*:*:*:wordpress:*:* Versions before 2.1.1 Vulnerable ·Androidbubbles

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-3895
  2. 2026-10-03 Alias added: GHSA-6r8w-jhg7-gpr9

References

  • TI-2025-07361 Injection Guard < 1.2.8 - Reflected XSS via $_SERVER['REQUEST_URI'] CVSS 3.1MEDIUM 6.1
  • TI-2025-07132 WP Shopify < 1.5.4 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2024-09127 RSS Feed Widget < 3.0.1 - Reflected XSS CVSS 3.1MEDIUM 4.8
  • TI-2025-11633 Easy Upload Files During Checkout <= 2.9.8 - Unauthenticated Arbitrary JavaScript File Upload CVSS 3.1CRITICAL 9.8
  • TI-2026-02908 Injection Guard <= 1.2.9 - Unauthenticated Stored Cross-Site Scripting via Query Parameter Name CVSS 3.1HIGH 7.2
  • TI-2024-23564 WordPress WP Docs plugin <= 2.1.3 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
See all 17 →

Sources