Product Enquiry for WooCommerce < 3.1.8 - Admin+ Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Product Enquiry for WooCommerce WordPress plugin before 3.1.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Product Enquiry for WooCommerce (Unknown): 3.1.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Product Enquiry for WooCommerce | before 3.1.8 | 3.1.8 | Patch available | CNA |
- Product Enquiry for WooCommerce VendorUnknown Affected before 3.1.8 Fixed in 3.1.8 Patch available CNA
Remediation
- Fix · CNA Product Enquiry for WooCommerce (Unknown) Fixed in 3.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3964
- 2026-10-03 Alias added: GHSA-xrmh-26m7-8f7p
References
Sources
- CVE-2024-3964 · CVE Program
- CVE-2024-3964 · NVD
- FIRST EPSS
- GHSA-xrmh-26m7-8f7p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences