Gutenberg Blocks by Kadence Blocks < 3.2.37 - Contributor+ Stored XSS
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Gutenberg Blocks with AI by Kadence WP WordPress plugin before 3.2.37 does not validate and escape some of its block attributes before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00367 30th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Gutenberg Blocks with AI by Kadence WP (Unknown): 3.2.37
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Gutenberg Blocks with AI by Kadence WP | before 3.2.37 | 3.2.37 | Patch available | CNA |
- Gutenberg Blocks with AI by Kadence WP VendorUnknown Affected before 3.2.37 Fixed in 3.2.37 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kadencewp:gutenberg_blocks_with_ai:*:*:*:*:*:wordpress:*:* | before 3.2.27 | Vulnerable | Kadence WP |
- cpe:2.3:a:kadencewp:gutenberg_blocks_with_ai:*:*:*:*:*:wordpress:*:* Versions before 3.2.27 Vulnerable ·Kadence WP
Remediation
- Fix · CNA Gutenberg Blocks with AI by Kadence WP (Unknown) Fixed in 3.2.37
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4057
- 2026-10-03 Alias added: GHSA-j32x-p3fr-rqvr
References
More Kadence WP Gutenberg Blocks With Ai vulnerabilities
- TI-2024-02334 Gutenberg Blocks by Kadence Blocks < 3.2.26 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.5
- TI-2024-09858 Kadence Blocks < 3.2.54 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-06384 Gutenberg Blocks with AI by Kadence WP < 3.2.39 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2025-18470 WordPress Kadence Blocks plugin <= 3.3.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-06366 Server-side request forgery in stellarwp Kadence Blocks — Page Builder Toolkit for… CVSS 3.1HIGH 8.5
- TI-2024-15542 WordPress Kadence Blocks plugin <= 3.2.19 - Server Side Request Forgery (SSRF) vulnerability CVSS 3.1HIGH 7.7
Sources
- CVE-2024-4057 · CVE Program
- CVE-2024-4057 · NVD
- FIRST EPSS
- GHSA-j32x-p3fr-rqvr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences