Search & Replace < 3.2.2 - Admin+ SQL injection
Priority HIGH 65CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The Search & Replace WordPress plugin before 3.2.2 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks (such as within a multi-site network).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00444 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Search & Replace (Unknown): 3.2.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Search & Replace | before 3.2.2 | 3.2.2 | Patch available | CNA |
- Search & Replace VendorUnknown Affected before 3.2.2 Fixed in 3.2.2 Patch available CNA
Remediation
- Fix · CNA Search & Replace (Unknown) Fixed in 3.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4145
- 2026-10-03 Alias added: GHSA-q492-8r5j-853q
References
More WP Media Search & Replace vulnerabilities
- TI-2024-25993 WordPress Search & Replace plugin <= 3.2.2 - Deserialization of untrusted data vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-4145 · CVE Program
- CVE-2024-4145 · NVD
- FIRST EPSS
- GHSA-q492-8r5j-853q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences