EDB Postgres Advanced Server (EPAS) authenticated file read permissions bypass using edbldr
Priority LOW 34CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
All versions of EnterpriseDB Postgres Advanced Server (EPAS) from 15.0 prior to 15.7.0 and from 16.0 prior to 16.3.0 may allow users using edbldr to bypass role permissions from pg_read_server_files. This could allow low privilege users to read files to which they would not otherwise have access.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0053 45th percentileScored 2026-11-07
Fix Fixed EDB Postgres Advanced Server (EnterpriseDB): 15.7.0, 16.3.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| EnterpriseDB | EDB Postgres Advanced Server | 15.0 to before 15.7.0; 16.0 to before 16.3.0 | 15.7.0, 16.3.0 | Patch available | CNA |
- EDB Postgres Advanced Server VendorEnterpriseDB Affected 15.0 to before 15.7.0; 16.0 to before 16.3.0 Fixed in 15.7.0, 16.3.0 Patch available CNA
Remediation
- Fix · CNA EDB Postgres Advanced Server (EnterpriseDB) Fixed in 15.7.0, 16.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4545
- 2026-10-03 Alias added: GHSA-gxjf-5qf6-p29g
References
More EnterpriseDB vulnerabilities
- TI-2023-21738 An issue was discovered in EnterpriseDB Postgres Advanced Server (EPAS) before 11.21.32… CVSS 3.1CRITICAL 9.8
- TI-2026-37400 When applying replicated changes for a row that is missing one or more columns, pglogical… CVSS 4.0CRITICAL 9.0
- TI-2026-37399 SQL injection in EnterpriseDB pglogical CVSS 4.0CRITICAL 9.0
- TI-2023-21739 An issue was discovered in EnterpriseDB Postgres Advanced Server (EPAS) before 11.21.32… CVSS 3.1HIGH 8.8
- TI-2026-63799 WarehousePG pg_file_write/pg_file_rename/pg_file_unlink/pg_logdir_ls privilege escalation CVSS 4.0HIGH 8.7
- TI-2023-21740 An issue was discovered in EnterpriseDB Postgres Advanced Server (EPAS) before 11.21.32… CVSS 3.1HIGH 8.8
Sources
- CVE-2024-4545 · CVE Program
- CVE-2024-4545 · NVD
- FIRST EPSS
- GHSA-gxjf-5qf6-p29g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences