An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES) when utilizing SAML single sign-on authentication with the optional encrypted assertions feature. This vulnerability allowed an attacker to forge a SAML response to provision and/or gain access to a user with site administrator privileges. Exploitation of this vulnerability would allow unauthorized access to the instance without requiring prior authentication. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.13.0 and was fixed in versions 3.9.15, 3.10.12, 3.11.10 and 3.12.4. This vulnerability was reported via the GitHub Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.9.0 – 3.9.14; 3.10.0 – 3.10.11; 3.11.0 – 3.11.9; 3.12.0 – 3.12.3 | 3.13.0 | Patch available | CNA |
- Enterprise Server VendorGitHub Affected 3.9.0 – 3.9.14; 3.10.0 – 3.10.11; 3.11.0 – 3.11.9; 3.12.0 – 3.12.3 Fixed in 3.13.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.9.15; 3.10.0 to before 3.10.12; 3.11.0 to before 3.11.10; 3.12.0 to before 3.12.4 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.9.15; 3.10.0 to before 3.10.12; 3.11.0 to before 3.11.10; 3.12.0 to before 3.12.4 Vulnerable ·GitHub
Remediation
- Fix · CNA Enterprise Server (GitHub) Fixed in 3.13.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4985
- 2026-10-03 Alias added: GHSA-5pw9-f9r4-mv2r
References
More GitHub Enterprise Server vulnerabilities
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
- TI-2024-06303 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
Sources
- CVE-2024-4985 · CVE Program
- CVE-2024-4985 · NVD
- FIRST EPSS
- GHSA-5pw9-f9r4-mv2r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences