Server-side request forgery in GitHub Enterprise Server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
A server-side request forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to send crafted requests to internal services by exploiting insufficient input validation in an upload endpoint. By injecting path traversal content into request parameters, an attacker could bypass the intended request flow and redirect internal API calls, potentially accessing internal services and exposing sensitive credentials. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.17, 3.18.11, 3.19.8, 3.20.4, and 3.21.2. This vulnerability was reported via the GitHub Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.16.0 – 3.16.19; 3.17.0 – 3.17.16; 3.18.0 – 3.18.10; 3.19.0 – 3.19.7; 3.20.0 – 3.20.3; 3.21.0 to before 3.21.1 | 3.21.1 | Patch available | CNA |
- Enterprise Server VendorGitHub Affected 3.16.0 – 3.16.19; 3.17.0 – 3.17.16; 3.18.0 – 3.18.10; 3.19.0 – 3.19.7; 3.20.0 – 3.20.3; 3.21.0 to before 3.21.1 Fixed in 3.21.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | 3.16.0 to before 3.16.19; 3.17.0 to before 3.17.16; 3.18.0 to before 3.18.10; 3.19.0 to before 3.19.7; 3.20.0 to before 3.20.3 | Vulnerable | GitHub |
| cpe:2.3:a:github:enterprise_server:3.21.1:rc1:*:*:*:*:*:* | 3.21.1 rc1 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions 3.16.0 to before 3.16.19; 3.17.0 to before 3.17.16; 3.18.0 to before 3.18.10; 3.19.0 to before 3.19.7; 3.20.0 to before 3.20.3 Vulnerable ·GitHub
- cpe:2.3:a:github:enterprise_server:3.21.1:rc1:*:*:*:*:*:* Versions 3.21.1 rc1 Vulnerable ·GitHub
Remediation
- Fix · CNA Enterprise Server (GitHub) Fixed in 3.21.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-9312
- 2026-10-03 Alias added: GHSA-fwfp-h68w-2hcr
- 2026-10-25 EPSS moved to the 95th–99th percentile
References
Other 5
- https://docs.github.com/en/[email protected]/admin/release-notes#3.17.17
- https://docs.github.com/en/[email protected]/admin/release-notes#3.18.11
- https://docs.github.com/en/[email protected]/admin/release-notes#3.19.8
- https://docs.github.com/en/[email protected]/admin/release-notes#3.20.4
- https://docs.github.com/en/[email protected]/admin/release-notes#3.21.2
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2024-06303 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
Sources
- CVE-2026-9312 · CVE Program
- CVE-2026-9312 · NVD
- FIRST EPSS
- GHSA-fwfp-h68w-2hcr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences