Uncontrolled search path in Canonical wpa_supplicant
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-427.
Summary
An issue was discovered in Ubuntu wpa_supplicant that resulted in loading of arbitrary shared objects, which allows a local unprivileged attacker to escalate privileges to the user that wpa_supplicant runs as (usually root). Membership in the netdev group or access to the dbus interface of wpa_supplicant allow an unprivileged user to specify an arbitrary path to a module to be loaded by the wpa_supplicant process; other escalation paths might exist.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | wpa_supplicant | 2:2.10-15 to before 2:2.10-21ubuntu0.1; 2:2.9.0-21build1 to before 2:2.10-6ubuntu2.1; 2:2.9-1ubuntu2 to before 2:2.9-1ubuntu4.4; 2.4-0ubuntu10 to before 2:2.6-15ubuntu2.8+esm1; 2.4-0ubuntu3 to before 2.4-0ubuntu6.8+esm1; 2.1-0ubuntu1 to before 2.1-0ubuntu1.7+esm5 | 2:2.10-21ubuntu0.1, 2:2.10-6ubuntu2.1, 2:2.9-1ubuntu4.4, 2:2.6-15ubuntu2.8+esm1, 2.4-0ubuntu6.8+esm1, 2.1-0ubuntu1.7+esm5 | Patch available | CNA |
- wpa_supplicant VendorCanonical Affected 2:2.10-15 to before 2:2.10-21ubuntu0.1; 2:2.9.0-21build1 to before 2:2.10-6ubuntu2.1; 2:2.9-1ubuntu2 to before 2:2.9-1ubuntu4.4; 2.4-0ubuntu10 to before 2:2.6-15ubuntu2.8+esm1; 2.4-0ubuntu3 to before 2.4-0ubuntu6.8+esm1; 2.1-0ubuntu1 to before 2.1-0ubuntu1.7+esm5 Fixed in 2:2.10-21ubuntu0.1, 2:2.10-6ubuntu2.1, 2:2.9-1ubuntu4.4, 2:2.6-15ubuntu2.8+esm1, 2.4-0ubuntu6.8+esm1, 2.1-0ubuntu1.7+esm5 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:w1.fi:wpa_supplicant:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Wi-Fi Alliance |
| cpe:2.3:o:canonical:ubuntu_linux:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Canonical |
- cpe:2.3:a:w1.fi:wpa_supplicant:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Wi-Fi Alliance
- cpe:2.3:o:canonical:ubuntu_linux:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Canonical
Remediation
- Fix · CNA wpa_supplicant (Canonical Ltd.) Fixed in 2:2.10-21ubuntu0.1, 2:2.10-6ubuntu2.1, 2:2.9-1ubuntu4.4, 2:2.6-15ubuntu2.8+esm1, 2.4-0ubuntu6.8+esm1, 2.1-0ubuntu1.7+esm5
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
Not affected: 2 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5290
- 2026-10-03 Alias added: GHSA-c2m5-cmpw-rjcx
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
More Canonical vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-5290 · CVE Program
- CVE-2024-5290 · NVD
- FIRST EPSS
- GHSA-c2m5-cmpw-rjcx · GitHub Advisory Database · CC BY 4.0
- CVE-2024-5290 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences