If-So Dynamic Content Personalization < 1.8.0.3 - Contributor+ Shortcode Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The If-So Dynamic Content Personalization WordPress plugin before 1.8.0.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00318 24th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed If-So Dynamic Content Personalization (Unknown): 1.8.0.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | If-So Dynamic Content Personalization | before 1.8.0.3 | 1.8.0.3 | Patch available | CNA |
- If-So Dynamic Content Personalization VendorUnknown Affected before 1.8.0.3 Fixed in 1.8.0.3 Patch available CNA
Remediation
- Fix · CNA If-So Dynamic Content Personalization (Unknown) Fixed in 1.8.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5440
- 2026-10-03 Alias added: GHSA-559f-7rvx-wm9p
References
More ifso Dynamic Content Personalization vulnerabilities
- TI-2023-28144 WordPress If-So Dynamic Content Personalization Plugin <= 1.6.3.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-5440 · CVE Program
- CVE-2024-5440 · NVD
- FIRST EPSS
- GHSA-559f-7rvx-wm9p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences