Read the docs

ifso

Records8All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high0CVSS 7.0–8.9

Exploited now

ifso records in CISA KEV

No ifso vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

8 records

TI-2024-05307 CVE-2024-5713 · GHSA-fgr7-28x3-54q4

if-so < 1.8.0.4 - Reflected XSS

Priority MEDIUM 58

The If-So Dynamic Content Personalization WordPress plugin before 1.8.0.4 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scriptin…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00353 Published 2024-07-13 Fixed in 1.8.0.4 CWE-79
Priority MEDIUM 58

The If-So Dynamic Content Personalization WordPress plugin before 1.8.0.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00318 Published 2025-05-15 Fixed in 1.8.0.3 CWE-79
TI-2024-05626 CVE-2024-6070 · GHSA-7rh6-j5jq-q5m7

if-so < 1.8.0.4 - Admin+ Stored XSS

Priority MEDIUM 55

The If-So Dynamic Content Personalization WordPress plugin before 1.8.0.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting att…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00374 Published 2024-07-13 Fixed in 1.8.0.4 CWE-79
Priority LOW 29

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in If So Plugin If-So Dynamic Content Personalization allows Stored XSS.This issue affects If-So Dynamic Content Personal…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00328 Published 2024-02-10 No fix listed CWE-79
Priority LOW 28

The If-So Dynamic Content – Elementor & All Page Builders Personalization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'repeater[*][version_uid] (and many sibling fields: freeze-mode, cookie-…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00206 Published 2026-10-28 No fix listed CWE-79
Priority LOW 28

The If-So Dynamic Content – Elementor & All Page Builders Personalization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'conversion' Shortcode Attribute in all versions up to, and including, 1.10.…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00243 Published 2026-10-28 No fix listed CWE-79
Priority LOW 28

The If-So Dynamic Content – Elementor & All Page Builders Personalization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'url' parameter in all versions up to, and including, 1.10.2 due to insu…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00243 Published 2026-10-28 No fix listed CWE-79
Open these records in search →