WP QuickLaTeX < 3.8.7 - Admin+ Stored XSS in Background Color field
Priority MEDIUM 64CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP QuickLaTeX WordPress plugin before 3.8.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00432 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP QuickLaTeX (Unknown): 3.8.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP QuickLaTeX | before 3.8.7 | 3.8.7 | Patch available | CNA |
- WP QuickLaTeX VendorUnknown Affected before 3.8.7 Fixed in 3.8.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:holoborodko:wp_quicklatex:*:*:*:*:*:wordpress:*:* | before 3.8.7 | Vulnerable | Holoborodko |
- cpe:2.3:a:holoborodko:wp_quicklatex:*:*:*:*:*:wordpress:*:* Versions before 3.8.7 Vulnerable ·Holoborodko
Remediation
- Fix · CNA WP QuickLaTeX (Unknown) Fixed in 3.8.7
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5472
- 2026-10-03 Alias added: GHSA-33v5-9rfm-w3f4
References
More Holoborodko Wp Quicklatex vulnerabilities
- TI-2024-05140 WP QuickLaTeX < 3.8.8 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-5472 · CVE Program
- CVE-2024-5472 · NVD
- FIRST EPSS
- GHSA-33v5-9rfm-w3f4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences