Open redirect in Citrix NetScaler ADC
Priority LOW 30CWE-601Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-601.
Summary
Open redirect vulnerability allows a remote unauthenticated attacker to redirect users to arbitrary websites in NetScaler ADC and NetScaler Gateway
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00552 46th percentileScored 2026-11-07
Fix Fixed NetScaler ADC (NetSclaer): 25.53, 53.17, 92.13 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Citrix | NetScaler ADC | 14.1 to before 25.53; 13.1 to before 53.17; 13.0 to before 92.13; 13.1-FIPS to before 37.183; 12.1-FIPS to before 55.304; 12.1-NDcPP to before 55.304 | 25.53, 53.17, 92.13, 37.183, 55.304 | Patch available | CNA |
- NetScaler ADC VendorCitrix Affected 14.1 to before 25.53; 13.1 to before 53.17; 13.0 to before 92.13; 13.1-FIPS to before 37.183; 12.1-FIPS to before 55.304; 12.1-NDcPP to before 55.304 Fixed in 25.53, 53.17, 92.13, 37.183, 55.304 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:fips:*:*:* | 12.1 to before 12.1-55.304 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:ndcpp:*:*:* | 12.1 to before 12.1-55.304 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:-:*:*:* | 12.1 to before 13.0-92.31 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:fips:*:*:* | 13.1 to before 13.1-37.183 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:-:*:*:* | 13.1 to before 13.1-53.17; 14.1 to before 14.1-25.53 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_gateway:*:*:*:*:*:*:*:* | 12.1 to before 13.0-92.31; 13.1 to before 13.1-53.17; 14.1 to before 14.1-25.53 | Vulnerable | Citrix |
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:fips:*:*:* Versions 12.1 to before 12.1-55.304 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:ndcpp:*:*:* Versions 12.1 to before 12.1-55.304 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:-:*:*:* Versions 12.1 to before 13.0-92.31 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:fips:*:*:* Versions 13.1 to before 13.1-37.183 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:-:*:*:* Versions 13.1 to before 13.1-53.17; 14.1 to before 14.1-25.53 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_gateway:*:*:*:*:*:*:*:* Versions 12.1 to before 13.0-92.31; 13.1 to before 13.1-53.17; 14.1 to before 14.1-25.53 Vulnerable ·Citrix
Remediation
- Fix · CNA NetScaler ADC (NetSclaer) Fixed in 25.53, 53.17, 92.13, 37.183, 55.304
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5492
- 2026-10-03 Alias added: GHSA-wj5r-m28j-95q9
References
More Citrix Netscaler Application Delivery Controller vulnerabilities
- TI-2026-60195 Memory overflow vulnerability leading to Remote Code Execution or Denial of Service KEVCVSS 4.0CRITICAL 9.5
- TI-2026-60194 Improper input validation in Citrix ADC KEVCVSS 4.0CRITICAL 9.5
- TI-2023-04571 Unauthenticated sensitive information disclosure in Citrix NetScaler ADC KEVCVSS 3.1CRITICAL 9.4
- TI-2023-03284 Unauthenticated remote code execution in Citrix NetScaler ADC KEVCVSS 3.1CRITICAL 9.8
- TI-2026-15872 NetScaler ADC and NetScaler Gateway Security Bulletin for CVE-2026-19490 KEVCVSS 4.0CRITICAL 9.3
- TI-2026-02639 Insufficient input validation leading to memory overread KEVCVSS 4.0CRITICAL 9.3
Sources
- CVE-2024-5492 · CVE Program
- CVE-2024-5492 · NVD
- FIRST EPSS
- GHSA-wj5r-m28j-95q9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences