Popup Maker < 1.19.1 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Popup Maker WordPress plugin before 1.19.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00467 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Popup Maker (Unknown): 1.19.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Popup Maker | before 1.19.1 | 1.19.1 | Patch available | CNA |
- Popup Maker VendorUnknown Affected before 1.19.1 Fixed in 1.19.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:code-atlantic:popup_maker:*:*:*:*:*:wordpress:*:* | before 1.19.1 | Vulnerable | danieliser |
- cpe:2.3:a:code-atlantic:popup_maker:*:*:*:*:*:wordpress:*:* Versions before 1.19.1 Vulnerable ·danieliser
Remediation
- Fix · CNA Popup Maker (Unknown) Fixed in 1.19.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5561
- 2026-10-03 Alias added: GHSA-8g86-p27w-cfrf
References
More danieliser Popup Maker vulnerabilities
- TI-2022-04012 Popup Maker < 1.16.9 - Contributor+ Stored XSS via Subscription Form CVSS 3.1MEDIUM 5.4
- TI-2022-03995 Popup Maker < 1.16.9 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2022-03392 Popup Maker < 1.16.11 - Contributor+ Stored Cross Site Scripting CVSS 3.1MEDIUM 5.5
- TI-2022-00999 Popup Maker < 1.16.5 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2019-13116 An issue was discovered in the Popup Maker plugin before 1.8.13 for WordPress. CVSS 3.1CRITICAL 9.1
- TI-2024-31676 WordPress Popup Maker plugin <= 1.19.2 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-5561 · CVE Program
- CVE-2024-5561 · NVD
- FIRST EPSS
- GHSA-8g86-p27w-cfrf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences