Limited DoS due to permitting creating users with user-defined IDs
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-284.
Summary
Mattermost versions 9.8.0, 9.7.x <= 9.7.4, 9.6.x <= 9.6.2, 9.5.x <= 9.5.5 fail to prevent specifying a RemoteId when creating a new user which allows an attacker to specify both a remoteId and the user ID, resulting in creating a user with a user-defined user ID. This can cause some broken functionality in User Management such administrative actions against the user not working.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 9.8.0; 9.7.0 – 9.7.4; 9.6.0 – 9.6.2; 9.5.0 – 9.5.5 | 9.9.0, 9.8.1, 9.7.5, 9.6.3, 9.5.6 | Patch available | CNA |
- Mattermost VendorMattermost Affected 9.8.0; 9.7.0 – 9.7.4; 9.6.0 – 9.6.2; 9.5.0 – 9.5.5 Fixed in 9.9.0, 9.8.1, 9.7.5, 9.6.3, 9.5.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* | 9.5.0 to before 9.5.6; 9.6.0 to before 9.6.3; 9.7.0 to before 9.7.5; 9.8.0 to before 9.8.1 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* Versions 9.5.0 to before 9.5.6; 9.6.0 to before 9.6.3; 9.7.0 to before 9.7.5; 9.8.0 to before 9.8.1 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 9.9.0, 9.8.1, 9.7.5, 9.6.3, 9.5.6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6428
- 2026-10-03 Alias added: GHSA-rvp5-8mrw-f62x
References
Advisory 1
More Mattermost vulnerabilities
- TI-2024-26695 Malicious remote can invite itself to an arbitrary local channel CVSS 3.1CRITICAL 9.6
- TI-2023-02056 Oauth authorization codes do not expire when deauthorizing an oauth2 app CVSS 3.1CRITICAL 9.1
- TI-2019-15069 An issue was discovered in Mattermost Mobile Apps before 1.26.0. CVSS 3.1CRITICAL 9.1
- TI-2024-26233 Malicious remote can add users to arbitrary teams and channels CVSS 3.1HIGH 8.7
- TI-2024-26746 Permanently local data deletion by malicious remote CVSS 3.1HIGH 8.7
- TI-2023-06508 Injection in Mattermost CVSS 3.1HIGH 8.8
Sources
- CVE-2024-6428 · CVE Program
- CVE-2024-6428 · NVD
- FIRST EPSS
- GHSA-rvp5-8mrw-f62x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences