Event Tickets with Ticket Scanner < 2.3.8 - Admin+ Stored XSS
Priority MEDIUM 50CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Event Tickets with Ticket Scanner WordPress plugin before 2.3.8 does not sanitise and escape some parameters, which could allow users with a role as low as admin to perform Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00331 26th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Event Tickets with Ticket Scanner (Unknown): 2.3.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Event Tickets with Ticket Scanner | before 2.3.8 | 2.3.8 | Patch available | CNA |
- Event Tickets with Ticket Scanner VendorUnknown Affected before 2.3.8 Fixed in 2.3.8 Patch available CNA
Remediation
- Fix · CNA Event Tickets with Ticket Scanner (Unknown) Fixed in 2.3.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6711
- 2026-10-03 Alias added: GHSA-chgf-rv7c-3x2f
References
More Vollstart Event Tickets With Ticket Scanner vulnerabilities
- TI-2025-01518 Event Tickets with Ticket Scanner < 2.5.4 - Arbitrary Tickets Deletion via CSRF CVSS 3.1MEDIUM 4.3
- TI-2024-35098 WordPress Event Tickets with Ticket Scanner plugin <= 2.3.11 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.9
- TI-2024-23521 WordPress Event Tickets with Ticket Scanner plugin <= 2.3.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2024-6711 · CVE Program
- CVE-2024-6711 · NVD
- FIRST EPSS
- GHSA-chgf-rv7c-3x2f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences