Read the docs
TI-2024-06295 Aliases CVE-2024-6792GHSA-h2c8-c64m-w4qp

WP ULike < 4.7.2.1 - Subscriber+ Stored-XSS

Priority MEDIUM 50CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The WP ULike WordPress plugin before 4.7.2.1 does not properly sanitize user display names when rendering on a public page.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00377 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP ULike (Unknown): 4.7.2.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP ULike4.7.1 to before 4.7.2.14.7.2.1Patch availableCNA
  • WP ULike VendorUnknown Affected 4.7.1 to before 4.7.2.1 Fixed in 4.7.2.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:technowich:wp_ulike:*:*:*:*:*:wordpress:*:*before 4.7.2.1VulnerableTechnoWich
  • cpe:2.3:a:technowich:wp_ulike:*:*:*:*:*:wordpress:*:* Versions before 4.7.2.1 Vulnerable ·TechnoWich

Remediation

  • Fix · CNA WP ULike (Unknown) Fixed in 4.7.2.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-6792
  2. 2026-10-03 Alias added: GHSA-h2c8-c64m-w4qp

References

  • TI-2024-11834 WP ULike < 4.7.6 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-07303 WP ULike < 4.7.5 - Admin+ Stored XSS via Widgets CVSS 3.1MEDIUM 4.8
  • TI-2024-07302 WP ULike < 4.7.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-05647 WP ULike < 4.7.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2022-22645 WordPress WP ULike Plugin <= 4.6.4 is vulnerable to Race Condition vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2023-24441 WordPress WP ULike Plugin <= 4.6.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources