WP ULike < 4.7.5 - Admin+ Stored XSS via Widgets
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP ULike WordPress plugin before 4.7.5 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0033 26th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP ULike (Unknown): 4.7.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP ULike | before 4.7.5 | 4.7.5 | Patch available | CNA |
- WP ULike VendorUnknown Affected before 4.7.5 Fixed in 4.7.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:technowich:wp_ulike:*:*:*:*:*:wordpress:*:* | before 4.7.5 | Vulnerable | TechnoWich |
- cpe:2.3:a:technowich:wp_ulike:*:*:*:*:*:wordpress:*:* Versions before 4.7.5 Vulnerable ·TechnoWich
Remediation
- Fix · CNA WP ULike (Unknown) Fixed in 4.7.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7879
- 2026-10-03 Alias added: GHSA-36q8-mfw8-2m98
References
More TechnoWich Wp Ulike vulnerabilities
- TI-2024-11834 WP ULike < 4.7.6 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-07302 WP ULike < 4.7.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-05647 WP ULike < 4.7.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-06295 WP ULike < 4.7.2.1 - Subscriber+ Stored-XSS CVSS 3.1LOW 3.5
- TI-2022-22645 WordPress WP ULike Plugin <= 4.6.4 is vulnerable to Race Condition vulnerability CVSS 3.1MEDIUM 5.3
- TI-2023-24441 WordPress WP ULike Plugin <= 4.6.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-7879 · CVE Program
- CVE-2024-7879 · NVD
- FIRST EPSS
- GHSA-36q8-mfw8-2m98 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences