Read the docs
TI-2024-07193 Aliases CVE-2024-7759GHSA-9m4x-m322-8xcp

PWA For WP & AMP < 1.7.72 Administrator+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The PWA for WP WordPress plugin before 1.7.72 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed PWA for WP (Unknown): 1.7.72

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPWA for WPbefore 1.7.721.7.72Patch availableCNA
  • PWA for WP VendorUnknown Affected before 1.7.72 Fixed in 1.7.72 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:magazine3:pwa_for_wp_\&_amp:*:*:*:*:*:wordpress:*:*before 1.7.72Vulnerablemagazine3
  • cpe:2.3:a:magazine3:pwa_for_wp_\&_amp:*:*:*:*:*:wordpress:*:* Versions before 1.7.72 Vulnerable ·magazine3

Remediation

  • Fix · CNA PWA for WP (Unknown) Fixed in 1.7.72

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-7759
  2. 2026-10-03 Alias added: GHSA-9m4x-m322-8xcp

References

  • TI-2021-03211 PWA for WP & AMP <= 1.7.32 - Arbitrary File Upload CVSS 3.1HIGH 8.8
  • TI-2024-31636 WordPress PWA for WP & AMP plugin <= 1.7.72 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2021-03223 PWA for WP & AMP < = 1.7.32 - Missing Authorization CVSS 3.1MEDIUM 6.3

Sources