Registrations for The Events Calendar < 2.12.4 - Unauthenticated Stored XSS
Priority HIGH 76CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Registrations for the Events Calendar WordPress plugin before 2.12.4 does not sanitise and escape some parameters when accepting event registrations, which could allow unauthenticated users to perform Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00726 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Registrations for the Events Calendar (Unknown): 2.12.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Registrations for the Events Calendar | before 2.12.4 | 2.12.4 | Patch available | CNA |
- Registrations for the Events Calendar VendorUnknown Affected before 2.12.4 Fixed in 2.12.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:roundupwp:registrations_for_the_events_calendar:*:*:*:*:*:wordpress:*:* | before 2.12.4 | Vulnerable | Roundup WP |
- cpe:2.3:a:roundupwp:registrations_for_the_events_calendar:*:*:*:*:*:wordpress:*:* Versions before 2.12.4 Vulnerable ·Roundup WP
Remediation
- Fix · CNA Registrations for the Events Calendar (Unknown) Fixed in 2.12.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7982
- 2026-10-03 Alias added: GHSA-wfm8-vp3v-66hp
References
More Roundup WP Registrations For The Events Calendar vulnerabilities
- TI-2024-09918 Registrations for The Events Calendar < 2.13.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2021-07222 Registrations for the Events Calendar < 2.7.6 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-26562 WordPress Registrations for the Events Calendar plugin <= 2.12.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2021-07158 Registrations for The Events Calendar < 2.7.5 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2021-07361 Registrations for the Events Calendar < 2.7.10 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-7982 · CVE Program
- CVE-2024-7982 · NVD
- FIRST EPSS
- GHSA-wfm8-vp3v-66hp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences