Registrations for The Events Calendar < 2.13.4 - Admin+ Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Registrations for the Events Calendar WordPress plugin before 2.13.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00279 20th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Registrations for the Events Calendar (Unknown): 2.13.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Registrations for the Events Calendar | before 2.13.4 | 2.13.4 | Patch available | CNA |
- Registrations for the Events Calendar VendorUnknown Affected before 2.13.4 Fixed in 2.13.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:roundupwp:registrations_for_the_events_calendar:*:*:*:*:*:wordpress:*:* | before 2.13.4 | Vulnerable | Roundup WP |
- cpe:2.3:a:roundupwp:registrations_for_the_events_calendar:*:*:*:*:*:wordpress:*:* Versions before 2.13.4 Vulnerable ·Roundup WP
Remediation
- Fix · CNA Registrations for the Events Calendar (Unknown) Fixed in 2.13.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10703
- 2026-10-03 Alias added: GHSA-ffm9-v534-h8c2
References
More Roundup WP Registrations For The Events Calendar vulnerabilities
- TI-2024-07401 Registrations for The Events Calendar < 2.12.4 - Unauthenticated Stored XSS CVSS 3.1CRITICAL 9.6
- TI-2021-07222 Registrations for the Events Calendar < 2.7.6 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-26562 WordPress Registrations for the Events Calendar plugin <= 2.12.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2021-07158 Registrations for The Events Calendar < 2.7.5 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2021-07361 Registrations for the Events Calendar < 2.7.10 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-10703 · CVE Program
- CVE-2024-10703 · NVD
- FIRST EPSS
- GHSA-ffm9-v534-h8c2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences