Read the docs
TI-2024-07515 Aliases CVE-2024-8104GHSA-7hvr-66jc-2p7f

Path traversal in wpextended The Ultimate WordPress Toolkit – WP Extended

Priority MEDIUM 42CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 3.0.8 via the download_file_ajax function. This makes it possible for authenticated attackers, with subscriber access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00957 61st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpextendedThe Ultimate WordPress Toolkit – WP Extendedup to 3.0.8—No fix listedCNA
  • The Ultimate WordPress Toolkit – WP Extended Vendorwpextended Affected up to 3.0.8 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:wordpress:*:*before 3.0.9Vulnerablewpextended
  • cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:wordpress:*:* Versions before 3.0.9 Vulnerable ·wpextended

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-8104
  2. 2026-10-03 Alias added: GHSA-7hvr-66jc-2p7f

References

  • TI-2024-07513 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2024-24774 WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-11055 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 7.4
  • TI-2024-12595 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1MEDIUM 5.3
  • TI-2024-07517 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Sensitive Information Exposure CVSS 3.1MEDIUM 6.5
  • TI-2024-08671 The Ultimate WordPress Toolkit – WP Extended <= 3.0.9 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
See all 10 →

Sources