WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Extended The Ultimate WordPress Toolkit – WP Extended wpextended.This issue affects The Ultimate WordPress Toolkit – WP Extended: from n/a through <= 2.4.7.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00624 50th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpextended | The Ultimate WordPress Toolkit – WP Extended | up to 2.4.7 | — | No fix listed | CNA |
- The Ultimate WordPress Toolkit – WP Extended Vendorwpextended Affected up to 2.4.7 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:wordpress:*:* | before 3.0.0 | Vulnerable | wpextended |
- cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:wordpress:*:* Versions before 3.0.0 Vulnerable ·wpextended
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-37259
- 2026-10-03 Alias added: GHSA-c4x4-cgpc-c2rw
- 2026-11-03 EPSS moved to the 50th–90th percentile
References
More wpextended Wp Extended vulnerabilities
- TI-2024-07515 Path traversal in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-07513 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2024-11055 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 7.4
- TI-2024-12595 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1MEDIUM 5.3
- TI-2024-07517 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Sensitive Information Exposure CVSS 3.1MEDIUM 6.5
- TI-2024-08671 The Ultimate WordPress Toolkit – WP Extended <= 3.0.9 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-37259 · CVE Program
- CVE-2024-37259 · NVD
- FIRST EPSS
- GHSA-c4x4-cgpc-c2rw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences