Read the docs
TI-2024-07606 Aliases CVE-2024-8207GHSA-52jj-6w68-3m25

MongoDB Server binaries may load potentially insecure shared libraries from specific relative paths

Priority LOW 31CWE-114Published · Updated

Key facts

Attack vector
Local
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

In certain highly specific configurations of the host system and MongoDB server binary installation on Linux Operating Systems, it may be possible for a unintended actor with host-level access to cause the MongoDB Server binary to load unintended actor-controlled shared libraries when the server binary is started, potentially resulting in the unintended actor gaining full control over the MongoDB server process. This issue affects MongoDB Server v5.0 versions prior to 5.0.14 and MongoDB Server v6.0 versions prior to 6.0.3. Required Configuration: Only environments with Linux as the underlying operating system is affected by this issue

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00205 10th percentileScored 2026-11-07
Fix Fixed MongoDB Server (MongoDB Inc): 6.0.3, 5.0.14

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MongoDBMongoDB Server6.0 to before 6.0.3; 5.0 to before 5.0.146.0.3, 5.0.14Patch availableCNA
  • MongoDB Server VendorMongoDB Affected 6.0 to before 6.0.3; 5.0 to before 5.0.14 Fixed in 6.0.3, 5.0.14 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:*5.0.0 to before 5.0.14; 6.0.0 to before 6.0.3; 6.1.0 to before 6.1.1VulnerableMongoDB
cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:*not specified by NVDRunning onLinux
  • cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.0.14; 6.0.0 to before 6.0.3; 6.1.0 to before 6.1.1 Vulnerable ·MongoDB
  • cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux

Remediation

  • Fix · CNA MongoDB Server (MongoDB Inc) Fixed in 6.0.3, 5.0.14

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-8207
  2. 2026-10-03 Alias added: GHSA-52jj-6w68-3m25

References

  • TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
  • TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
  • TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
  • TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
  • TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
  • TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
See all 187 →

Sources