The Events Calendar < 6.6.4 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Events Calendar WordPress plugin before 6.6.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00362 30th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed The Events Calendar (Unknown): 6.6.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | The Events Calendar | before 6.6.4 | 6.6.4 | Patch available | CNA |
- The Events Calendar VendorUnknown Affected before 6.6.4 Fixed in 6.6.4 Patch available CNA
Remediation
- Fix · CNA The Events Calendar (Unknown) Fixed in 6.6.4
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8493
- 2026-10-03 Alias added: GHSA-xc5x-xvcr-5h87
References
More stellarwp The Events Calendar vulnerabilities
- TI-2024-07671 The Events Calendar <= 6.6.4 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-03888 The Events Calendar < 6.4.0.1 - Reflected XSS CVSS 3.1CRITICAL 9.1
- TI-2024-04952 The Events Calendar < 6.8.2.1 - Unauthenticated Password Protected Event Disclosure CVSS 3.1MEDIUM 5.3
- TI-2024-06430 The Events Calendar <= 6.6.3 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2023-05697 The Events Calendar < 6.2.8.1 - Unauthenticated Arbitrary Password Protected Post Read CVSS 3.1HIGH 7.5
- TI-2019-11280 The the-events-calendar plugin before 4.8.2 for WordPress has XSS via the tribe_paged URL parameter. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2024-8493 · CVE Program
- CVE-2024-8493 · NVD
- FIRST EPSS
- GHSA-xc5x-xvcr-5h87 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences