Quiz and Survey Master (QSM) < 9.1.3 - Author+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Quiz and Survey Master (QSM) WordPress plugin before 9.1.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00396 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Quiz and Survey Master (QSM) (Unknown): 9.1.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Quiz and Survey Master (QSM) | before 9.1.3 | 9.1.3 | Patch available | CNA |
- Quiz and Survey Master (QSM) VendorUnknown Affected before 9.1.3 Fixed in 9.1.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:expresstech:quiz_and_survey_master:*:*:*:*:*:wordpress:*:* | before 9.1.3 | Vulnerable | ExpressTech |
- cpe:2.3:a:expresstech:quiz_and_survey_master:*:*:*:*:*:wordpress:*:* Versions before 9.1.3 Vulnerable ·ExpressTech
Remediation
- Fix · CNA Quiz and Survey Master (QSM) (Unknown) Fixed in 9.1.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8758
- 2026-10-03 Alias added: GHSA-wx2w-96rx-h8gc
References
More ExpressTech Quiz And Survey Master vulnerabilities
- TI-2020-18392 An issue was discovered in the Quiz and Survey Master plugin before 7.0.1 for WordPress. CVSS 3.1CRITICAL 9.9
- TI-2024-05207 Quiz And Survey Master < 9.0.2 - Contributor+ SQLi CVSS 3.1HIGH 8.8
- TI-2024-05583 Quiz and Survey Master < 9.0.5 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.5
- TI-2024-09897 Quiz and Survey Master (QSM) < 9.2.1 - Author+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2024-05932 Quiz and Survey Master (QSM) < 9.1.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2024-04590 Quiz And Survey Master < 9.0.2 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.5
Sources
- CVE-2024-8758 · CVE Program
- CVE-2024-8758 · NVD
- FIRST EPSS
- GHSA-wx2w-96rx-h8gc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences