Custom Twitter Feeds < 2.2.3 - Admin+ Stored XSS
Priority MEDIUM 55CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-77.
Summary
Custom Twitter Feeds WordPress plugin before 2.2.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00432 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Custom Twitter Feeds (Unknown): 2.2.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Custom Twitter Feeds | before 2.2.3 | 2.2.3 | Patch available | CNA |
- Custom Twitter Feeds VendorUnknown Affected before 2.2.3 Fixed in 2.2.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:smashballoon:custom_twitter_feeds:*:*:*:*:*:wordpress:*:* | before 2.2.3 | Vulnerable | Smash Balloon |
- cpe:2.3:a:smashballoon:custom_twitter_feeds:*:*:*:*:*:wordpress:*:* Versions before 2.2.3 Vulnerable ·Smash Balloon
Remediation
- Fix · CNA Custom Twitter Feeds (Unknown) Fixed in 2.2.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8983
- 2026-10-03 Alias added: GHSA-3v5j-fcwv-g4wv
References
More Smash Balloon Custom Twitter Feeds vulnerabilities
- TI-2023-28575 WordPress Custom Twitter Feeds (Tweets Widget) Plugin <= 2.1.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-14969 WordPress Custom Twitter Feeds (Tweets Widget) Plugin <= 1.8.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-33171 WordPress Custom Twitter Feeds plugin <= 2.2.3 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2024-00345 Custom Twitter Feeds – A Tweets Widget or X Feed Widget <= 2.2.1 - Cross-Site Request Forgery to Plugin Options Update CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-8983 · CVE Program
- CVE-2024-8983 · NVD
- FIRST EPSS
- GHSA-3v5j-fcwv-g4wv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences