Security Misconfiguration in Forge module PEADM
Priority LOW 24CWE-295Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-295.
Summary
In versions of the PEADM Forge Module prior to 3.24.0 a security misconfiguration was discovered.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00165 5th percentileScored 2026-11-07
Fix Fixed PEADM Forge Module (Puppet): 3.24.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA PEADM Forge Module (Puppet) Fixed in 3.24.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9160
- 2026-10-03 Alias added: GHSA-3c7c-8hj4-v9qh
References
More Puppet vulnerabilities
- TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
- TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
- TI-2022-03025 Puppetlabs-apt Command Injection CVSS 3.1CRITICAL 9.8
- TI-2016-02327 Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet… CVSS 3.1CRITICAL 9.8
- TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
- TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-9160 · CVE Program
- CVE-2024-9160 · NVD
- FIRST EPSS
- GHSA-3c7c-8hj4-v9qh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences