Read the docs
TI-2016-02327 Aliases CVE-2016-2785GHSA-pqj5-7r86-64fv

Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet…

Priority MEDIUM 47CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 6 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-284.

Summary

Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet Agent before 1.4.2 might allow remote attackers to bypass intended auth.conf access restrictions by leveraging incorrect URL decoding.

Why it matters now

EPSS 0.02889 86th percentileScored 2026-11-07
Fix Partial puppet (RubyGems): 4.4.2Red Hat: 6 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—puppet (RubyGems)4.0.0 to before 4.4.24.4.2Patch availableGHSA-pqj5-7r86-64fv
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • puppet (RubyGems) Vendor— Affected 4.0.0 to before 4.4.2 Fixed in 4.4.2 Patch available GHSA-pqj5-7r86-64fv

CPE configurations NVD · 22

CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet:4.0.0:*:*:*:*:*:*:*4.0.0VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.0.0:rc1:*:*:*:*:*:*4.0.0 rc1VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.0.0:rc2:*:*:*:*:*:*4.0.0 rc2VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.0.0:rc3:*:*:*:*:*:*4.0.0 rc3VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.1.0:*:*:*:*:*:*:*4.1.0VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.2.0:*:*:*:*:*:*:*4.2.0VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.2.1:*:*:*:*:*:*:*4.2.1VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.2.2:*:*:*:*:*:*:*4.2.2VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.2.3:*:*:*:*:*:*:*4.2.3VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.3.0:*:*:*:*:*:*:*4.3.0VulnerablePuppet
  • cpe:2.3:a:puppet:puppet:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.2.1:*:*:*:*:*:*:* Versions 4.2.1 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.2.2:*:*:*:*:*:*:* Versions 4.2.2 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.2.3:*:*:*:*:*:*:* Versions 4.2.3 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.3.0:*:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·Puppet
Show 12 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet:4.3.1:*:*:*:*:*:*:*4.3.1VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.3.2:*:*:*:*:*:*:*4.3.2VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.4.0:*:*:*:*:*:*:*4.4.0VulnerablePuppet
cpe:2.3:a:puppet:puppet:4.4.1:*:*:*:*:*:*:*4.4.1VulnerablePuppet
cpe:2.3:a:puppet:puppet_server:2.0.0:*:*:*:*:*:*:*2.0.0VulnerablePuppet
cpe:2.3:a:puppet:puppet_server:2.1.0:*:*:*:*:*:*:*2.1.0VulnerablePuppet
cpe:2.3:a:puppet:puppet_server:2.1.1:*:*:*:*:*:*:*2.1.1VulnerablePuppet
cpe:2.3:a:puppet:puppet_server:2.1.2:*:*:*:*:*:*:*2.1.2VulnerablePuppet
cpe:2.3:a:puppet:puppet_server:2.2.0:*:*:*:*:*:*:*2.2.0VulnerablePuppet
cpe:2.3:a:puppet:puppet_server:2.3.0:*:*:*:*:*:*:*2.3.0VulnerablePuppet
cpe:2.3:a:puppet:puppet_server:2.3.1:*:*:*:*:*:*:*2.3.1VulnerablePuppet
cpe:2.3:a:puppet:puppet_agent:1.4.1:*:*:*:*:*:*:*1.4.1VulnerablePuppet
  • cpe:2.3:a:puppet:puppet:4.3.1:*:*:*:*:*:*:* Versions 4.3.1 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.3.2:*:*:*:*:*:*:* Versions 4.3.2 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.4.0:*:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet:4.4.1:*:*:*:*:*:*:* Versions 4.4.1 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_server:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_server:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_server:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_server:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_server:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_server:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_server:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_agent:1.4.1:*:*:*:*:*:*:* Versions 1.4.1 Vulnerable ·Puppet

Remediation

  • Fix · GHSA-pqj5-7r86-64fv puppet (RubyGems) Fixed in 4.4.2 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenStack ForemanAffectedNo fix planned: Will not fix
Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux OpenStack Platform 6 (Juno)AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux OpenStack Platform 6 (Juno) InstallerAffectedNo fix planned: Will not fix
Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 8 (Liberty)AffectedNo fix planned: Will not fix
Not affected: 3 products
  • Red Hat Ceph Storage 1.3
  • Red Hat Satellite 6
  • Red Hat Subscription Asset Manager

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-2785
  2. 2026-10-03 Alias added: GHSA-pqj5-7r86-64fv

References

  • TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
  • TI-2021-08594 SQL injection in Puppet DB CVSS 3.1HIGH 8.8
  • TI-2017-01576 Deserialization of untrusted data in Puppet server CVSS 3.0HIGH 8.2
  • TI-2018-04793 Untrusted search path in Puppet Enterprise and Puppet Agent CVSS 3.0HIGH 8.8
  • TI-2013-01456 Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later… CVSS 2.0HIGH 7.5
  • TI-2013-01454 Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise… CVSS 2.0HIGH 7.1
See all 41 →

Sources