ThingsBoard HTTP RPC API resource consumption
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-400.
Summary
A vulnerability has been found in ThingsBoard up to 3.7.0 and classified as problematic. Affected by this vulnerability is an unknown functionality of the component HTTP RPC API. The manipulation leads to resource consumption. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.7.1 is able to address this issue. It is recommended to upgrade the affected component. The vendor was informed on 2024-07-24 about this vulnerability and announced the release of 3.7.1 for the second half of September 2024.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ThingsBoard | 3.0; 3.1; 3.2; 3.3; 3.4; 3.5; 3.6; 3.7 | — | No fix listed | CNA |
- ThingsBoard Vendor— Affected 3.0; 3.1; 3.2; 3.3; 3.4; 3.5; 3.6; 3.7 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thingsboard:thingsboard:*:*:*:*:*:*:*:* | up to 3.7 | Vulnerable | ThingsBoard |
- cpe:2.3:a:thingsboard:thingsboard:*:*:*:*:*:*:*:* Versions up to 3.7 Vulnerable ·ThingsBoard
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9358
- 2026-10-03 Alias added: GHSA-wgr5-rw77-5f6p
References
More Thingsboard vulnerabilities
- TI-2023-24282 ThingsBoard before 3.5 allows Server-Side Template Injection if users are allowed to… CVSS 3.1HIGH 8.8
- TI-2022-18942 Cross Site Scripting (XSS) vulnerability in Things Board 3.4.1 allows remote attackers to… CVSS 3.1CRITICAL 9.6
- TI-2022-23955 ThingsBoard 3.4.1 could allow a remote authenticated attacker to achieve Vertical… CVSS 3.1HIGH 8.8
- TI-2022-22507 An issue was discovered in ThingsBoard 3.4.1, allows low privileged attackers… CVSS 3.1HIGH 8.8
- TI-2020-16789 ThingsBoard before v3.2 is vulnerable to Host header injection in password-reset emails. CVSS 3.1HIGH 8.8
- TI-2025-24420 ThingsBoard < v4.2.1 SVG Image SSRF CVSS 4.0MEDIUM 6.9
Sources
- CVE-2024-9358 · CVE Program
- CVE-2024-9358 · NVD
- FIRST EPSS
- GHSA-wgr5-rw77-5f6p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences