Read the docs
TI-2024-08893 Aliases CVE-2024-9586GHSA-6f2w-qq5x-fpg9

Linkz.ai <= 1.1.8 - Missing Authorization to Unauthenticated Plugin Settings Update

Priority LOW 35CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The Linkz.ai plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'check_auth' and 'check_logout' functions in versions up to, and including, 1.1.8. This makes it possible for unauthenticated attackers to update plugin settings.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00447 39th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vittor1oLinkz.ai – Automatic link previews on hoverup to 1.1.8—No fix listedCNA
  • Linkz.ai – Automatic link previews on hover Vendorvittor1o Affected up to 1.1.8 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:linkz.ai:linkz.ai:*:*:*:*:*:wordpress:*:*before 1.2.0VulnerableLinkz.ai
  • cpe:2.3:a:linkz.ai:linkz.ai:*:*:*:*:*:wordpress:*:* Versions before 1.2.0 Vulnerable ·Linkz.ai

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-9586
  2. 2026-10-03 Alias added: GHSA-6f2w-qq5x-fpg9

References

  • TI-2024-08894 Linkz.ai <= 1.1.8 - Missing Authorization to Authenticated (Subscriber+) Plugin Settings Update via AJAX CVSS 3.1MEDIUM 5.4

Sources