Linkz.ai <= 1.1.8 - Missing Authorization to Authenticated (Subscriber+) Plugin Settings Update via AJAX
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Linkz.ai plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'ajax_linkz' function in versions up to, and including, 1.1.8. This makes it possible for authenticated attackers with contributor-level privileges or above, to update plugin settings.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vittor1o | Linkz.ai – Automatic link previews on hover | up to 1.1.8 | — | No fix listed | CNA |
- Linkz.ai – Automatic link previews on hover Vendorvittor1o Affected up to 1.1.8 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9587
- 2026-10-03 Alias added: GHSA-mpxq-m5x3-qf7f
References
More Linkz.ai vulnerabilities
- TI-2024-08893 Linkz.ai <= 1.1.8 - Missing Authorization to Unauthenticated Plugin Settings Update CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-9587 · CVE Program
- CVE-2024-9587 · NVD
- FIRST EPSS
- GHSA-mpxq-m5x3-qf7f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences