Category Posts Widget < 4.9.18 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Category Posts Widget WordPress plugin before 4.9.18 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00377 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Category Posts Widget (Unknown): 4.9.18
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Category Posts Widget | before 4.9.18 | 4.9.18 | Patch available | CNA |
- Category Posts Widget VendorUnknown Affected before 4.9.18 Fixed in 4.9.18 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zephyrwest:category_posts_widget:*:*:*:*:*:wordpress:*:* | before 4.9.18 | Vulnerable | Zephyrwest |
- cpe:2.3:a:zephyrwest:category_posts_widget:*:*:*:*:*:wordpress:*:* Versions before 4.9.18 Vulnerable ·Zephyrwest
Remediation
- Fix · CNA Category Posts Widget (Unknown) Fixed in 4.9.18
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9638
- 2026-10-03 Alias added: GHSA-w573-j2v8-vx6p
References
More Zephyrwest Category Posts Widget vulnerabilities
- TI-2025-01249 Category Posts Widget < 4.9.20 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-05707 Category Posts Widget (Free < 4.9.17, Pro < 4.9.13) - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-9638 · CVE Program
- CVE-2024-9638 · NVD
- FIRST EPSS
- GHSA-w573-j2v8-vx6p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences