Missing authorization in wpclever WPC Smart Messages for WooCommerce
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The WPC Smart Messages for WooCommerce plugin for WordPress is vulnerable to unauthorized Smar Message activation/deactivation due to a missing capability check on the ajax_enable function in all versions up to, and including, 4.2.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to activate or deactivate smart messages.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10437
- 2026-10-03 Alias added: GHSA-92qw-g99q-jr5r
References
Other 3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4acb4fda-0217-44b9-a85e-64807eb4a011?source=cve
- https://plugins.trac.wordpress.org/browser/wpc-smart-messages/tags/4.2.1/includes/class-backend.php#L775
- https://plugins.trac.wordpress.org/changeset/3177426/wpc-smart-messages/trunk/includes/class-backend.php?contextall=1
More wpclever vulnerabilities
- TI-2024-33849 WordPress WPC Shop as a Customer for WooCommerce plugin <= 1.2.6 - PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-22095 WordPress WPC Smart Linked Products plugin <= 1.3.5 - Privilege Escalation vulnerability CVSS 3.1HIGH 8.8
- TI-2025-22042 Missing authorization in wpclever WPC Smart Upsell Funnel for WooCommerce CVSS 3.1HIGH 8.8
- TI-2024-09664 WPC Smart Messages for WooCommerce <= 4.2.1 - Authenticated (Subscriber+) Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2026-63681 Improper privilege management in wpclever WPC Shop as a Customer for WooCommerce CVSS 3.1HIGH 8.8
- TI-2025-03002 WPC Admin Columns 2.0.6 - 2.1.0 - Authenticated (Subscriber+) Privilege Escalation via User Meta Update CVSS 3.1HIGH 8.8
Sources
- CVE-2024-10437 · CVE Program
- CVE-2024-10437 · NVD
- FIRST EPSS
- GHSA-92qw-g99q-jr5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences