Everest Forms < 3.0.4.2 - Admin+ Stored XSS
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Everest Forms WordPress plugin before 3.0.4.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00402 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Everest Forms (Unknown): 3.0.4.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Everest Forms | before 3.0.4.2 | 3.0.4.2 | Patch available | CNA |
- Everest Forms VendorUnknown Affected before 3.0.4.2 Fixed in 3.0.4.2 Patch available CNA
Remediation
- Fix · CNA Everest Forms (Unknown) Fixed in 3.0.4.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10471
- 2026-10-03 Alias added: GHSA-cpgg-w28j-jvph
References
More wpeverest Everest Forms vulnerabilities
- TI-2025-00958 Everest Forms <= 3.0.9.4 - Unauthenticated Arbitrary File Upload, Read, and Deletion CVSS 3.1CRITICAL 9.8
- TI-2024-07919 Everest Forms < 3.0.3.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2025-03022 Deserialization of untrusted data in wpeverest Everest Forms – Contact Form, Payment… CVSS 3.1CRITICAL 9.8
- TI-2024-12173 Everest Forms < 3.0.8.1 - Admin+ Stored XSS CVSS 3.1LOW 3.5
- TI-2019-10207 A SQL injection vulnerability exists in WPEverest Everest Forms plugin for WordPress… CVSS 3.1CRITICAL 9.8
- TI-2025-05353 Everest Forms (Pro) <= 1.9.4 - Unauthenticated Path Traversal to Arbitrary File Deletion CVSS 3.1HIGH 7.5
Sources
- CVE-2024-10471 · CVE Program
- CVE-2024-10471 · NVD
- FIRST EPSS
- GHSA-cpgg-w28j-jvph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences