Element Pack Elementor Addons < 5.10.3 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) WordPress plugin before 5.10.3 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) | before 5.10.3 | 5.10.3 | Patch available | CNA |
- Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) VendorUnknown Affected before 5.10.3 Fixed in 5.10.3 Patch available CNA
Remediation
- Fix · CNA Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel, Remote Arrows) (Unknown) Fixed in 5.10.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10493
- 2026-10-03 Alias added: GHSA-x944-3w5c-5hcg
References
More bdthemes Element Pack vulnerabilities
- TI-2024-10178 Element Pack Elementor Addons < 5.10.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-20220 WordPress Element Pack Lite plugin <= 5.5.3 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-02773 Information disclosure in bdthemes Element Pack – Widgets, Templates & Addons for… CVSS 3.1HIGH 7.5
- TI-2024-22155 WordPress Element Pack Pro plugin < 7.19.3 - Arbitrary File Read and Phar Deserialization vulnerability CVSS 3.1HIGH 8.5
- TI-2025-07410 Cross-site scripting in bdthemes Element Pack – Widgets, Templates & Addons for Elementor CVSS 3.1MEDIUM 5.4
- TI-2024-03665 Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-10493 · CVE Program
- CVE-2024-10493 · NVD
- FIRST EPSS
- GHSA-x944-3w5c-5hcg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences